यह टिप हर किसी के लिए उपयोगी नहीं होगी, लेकिन समर्पित सर्वर वाले किसी भी व्यक्ति के लिए आप शायद इस त्रुटि संदेश से परिचित होंगे जो आपके सर्वर पर सुरक्षा स्कैनर से साप्ताहिक रूप से भेजा जाता है।

टीवी के लिए जोड़ी रोकू रिमोट

मुझे सप्ताह में एक बार वॉचडॉग से मिलने वाला त्रुटि ईमेल इस तरह दिखता है:



सुरक्षा स्कैनिंग ने निम्नलिखित चेतावनियाँ उत्पन्न कीं (पूर्ण स्कैनिंग लॉग
/var/log/rkhunter.log पर उपलब्ध है):

[01:01:51] —————————————————————————————————————————————-
[01:01:52] चेतावनी: एसएसएच संस्करण 1 संभव की अनुमति है!

इस समस्या को ठीक करने के लिए, हमें sshd_config फ़ाइल को संपादित करना होगा, जो sshd सेवा के लिए मुख्य कॉन्फ़िगरेशन फ़ाइल है। स्थान कभी-कभी भिन्न होगा, लेकिन यह आमतौर पर /etc/ssh/ में होता है। रूट के रूप में लॉग ऑन रहते हुए फ़ाइल को खोलें।

नोट: सावधान रहें, यदि आप इसे खराब कर देते हैं तो आप अब अपने सर्वर पर ssh नहीं कर पाएंगे…

vi /etc/ssh/sshd_config

फ़ाइल में इस अनुभाग को ढूंढें, जिसमें प्रोटोकॉल वाली रेखा हो। यहां समस्या है... हमें sshd सेवा को केवल संस्करण 2 का उपयोग करने के लिए स्पष्ट रूप से बताना होगा।

#पोर्ट 22
#प्रोटोकॉल 2,1
#सुनो पता 0.0.0.0
#सुनो पता ::

विज्ञापन

यदि लाइन पर टिप्पणी की गई है या इसमें 2,1 दोनों हैं, तो आपको इसे इस तरह दिखाना होगा (अन्य पंक्तियों को अकेला छोड़ दें)

प्रोटोकॉल 2

अब आपको sshd सेवा को पुनरारंभ करना होगा:

/etc/init.d/sshd पुनरारंभ करें

आपको अब वे त्रुटि ईमेल नहीं मिलने चाहिए।

आगे पढ़िए
  • › कंप्यूटर फोल्डर 40 है: जेरोक्स स्टार ने डेस्कटॉप कैसे बनाया
  • › Microsoft Excel में फ़ंक्शन बनाम सूत्र: क्या अंतर है?
  • › 5 वेबसाइटें हर लिनक्स उपयोगकर्ता को बुकमार्क करनी चाहिए
  • › अपना Spotify रैप्ड 2021 कैसे खोजें
  • › एमआईएल-स्पेक ड्रॉप प्रोटेक्शन क्या है?
  • साइबर मंडे 2021: बेस्ट टेक डील
संपादक की पसंद